GET request to Cat API timing out as of today


#1

Has been working absolutely fine for me recently. Pretty confident it’s not my code because I haven’t updated the production build of my app for a couple of days and it was working perfectly fine yesterday and the day before. It’s been timing out all day, both on the production build and on my updated version (on which I’ve tried various configurations to try and fix it). Wondering if it’s just me experiencing this?


#2

It’s no you. The API is down - even the demo app doesn’t work: https://thecatapi.com/


#3

@Aden Check out https://tinpurr.netlify.com/ :slight_smile: (it uses touch events so check it out on mobile)

I had to switch out the base url for the dog API, would love to put cats back in here :slight_smile:


#4

Thanks! Glad to know it’s not just me.

Hehe, nice app! Definitely doesn’t look right with dogs lol


#5

Thanks for the notifications, it’s now back up and working normally.

Looks like there was an issue with a configuration update, I’ll do a full investigation today and find the cause.

If there’s anything failing then just let me know.
Best, Aden


#6

@anthonylebrun - your app is amazing, love the presentation. I’m really looking forward to seeing it with Kitties!


#7

Still doesn’t seem to be working for me. Same goes for the demo on the thecatapi.com homepage.


#8

Looks like the final server has updated, so whichever one you’re hitting it should now be fixed.

I’ll continue monitoring the situation, let me know if you still having issues and i’ll give the load balancer a shake.


#9

It works! (feels a bit sluggish maybe?)


#10

Thanks! Just to confirm it’s now working for me :slight_smile:

I must say it is also feeling slow for me too. Maybe 4 times slower response time than before.


#11

That is great news.

On the speed side, now things are stable i’ve turned the auto-scaling back on, which might make things a little choppy for the next few minutes, but will bring the speed back up.


#12

I’m still getting massive response times and 504 gateway timeouts

If that image doesn’t show up for you

curl https://api.thecatapi.com/api/images/get\?format\=json\&category\=ties                                                                  []
<html>
<head><title>504 Gateway Time-out</title></head>
<body bgcolor="white">
<center><h1>504 Gateway Time-out</h1></center>
</body>
</html>

#13

Hey Matt,

Thanks for letting me know, the majority of 504’s are sorted, and the response time is coming down - although it’s still well over a second which is far too long.

It’ll come down further through the day as updates & hardware come online, the traffic has been 100x today…


#14

New version of the API is live, and it’s brought the response time back down to sub ~15ms.

I’ll be writing up an incident report on the blog, and details to prevent a reoccurrence.

Thanks for you patience, any issues people see please let me know.


#15

Great! Thanks! :slight_smile: Working very nicely now


#16

Thanks @widget

I’ve published an incident report on the blog: https://thatapiguy.com/thecatapi-incident-report-15-17-11-2018/

And the IP to domain issue with this forum should be fixed now too.